Magento2 降级与升级的一些问题处理

Magento2 大家都试过升级,有没有试过降级,今天无意中,将测试的项目做了一次降级处理
php bin/magento --version
2.15
当时版本是2.15
composer require magento/product-community-edition 2.1.3 --no-update
composer update
没留意将2.2.3输入成了2.1.3,降级也要花很很长时间
发现完成后,转开发者模式,报错,有些是从末见过的,这里我就没列出来,因为没有截图。大多数是当前插件2.15版的插件无法向下兼容2.13导致的问题。
接亲想升级到2.2.3,升级到一半时,虚似机挂掉了,又改成还原吧,改为2.1.5整合过程费时间
接接完成安装,但还是报错
1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory.
The following modules are outdated:
Magento_Integration schema: current version - 2.2.0, required version - 2.0.1
Magento_Integration data: current version - 2.2.0, required version - 2.0.1
这里我就知道怎样处理了,Magento_Integration版本高了一点,先选用2.0.1,这里我是通过改数据库 setup_module 找到Magento_Integration 或搜2.2.0将成2.0.1
SELECT * FROM `setup_module` WHERE `schema_version` LIKE '%2.2.0%'
大功靠成,又找到一处错误,能够处理了,在升级与降级时注意官方的PHP 7的版本要求

发表评论
Magento2 技术支持 上门服务

工作时间
周一至周六
9:00-18:00
相关咨询电话
15360669780
侨海科技